aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d2febde..f017d6b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,8 +21,6 @@ add_executable(poi
singleapplication.h
browser.cpp
browser.h
- configuration.cpp
- configuration.h
../data/resources.qrc
# main window
@@ -74,11 +72,12 @@ add_executable(poi
../plugins/interfaces.h commandline.cpp commandline.h)
target_include_directories(poi
- PRIVATE ../lib ../plugins)
+ PRIVATE ../lib ../plugins
+ PRIVATE ../lib/configuration)
target_link_libraries(poi
Qt5::Core Qt5::Widgets Qt5::Concurrent Qt5::WebEngineWidgets
- ${Boost_LIBRARIES}
+ configuration
bookmarks downloads)
install(TARGETS poi RUNTIME DESTINATION bin CONFIGURATIONS Release)