aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt84
1 files changed, 84 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..d2febde
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,84 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTOUIC ON)
+set(CMAKE_AUTORCC ON)
+
+# configure a header file to pass version information
+# if you don't have git, or are building this off the source tarball, define versions in version.h.in
+execute_process(COMMAND hg log -r '.' --template={latesttag} WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE VcsVersion OUTPUT_STRIP_TRAILING_WHITESPACE)
+execute_process(COMMAND hg identify --id WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE VcsCommit OUTPUT_STRIP_TRAILING_WHITESPACE)
+execute_process(COMMAND hg identify --num WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE VcsRevision OUTPUT_STRIP_TRAILING_WHITESPACE)
+execute_process(COMMAND hg identify --branch WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE VcsBranch OUTPUT_STRIP_TRAILING_WHITESPACE)
+configure_file(version.h.in "${PROJECT_BINARY_DIR}/src/version.h")
+
+add_executable(poi
+ # main
+ main.cpp
+ singleapplication.cpp
+ singleapplication.h
+ browser.cpp
+ browser.h
+ configuration.cpp
+ configuration.h
+ ../data/resources.qrc
+
+ # main window
+ mainwindow/mainwindow.cpp
+ mainwindow/mainwindow.h
+ mainwindow/mainwindow.ui
+ mainwindow/widgets/loadingbar.cpp
+ mainwindow/widgets/loadingbar.h
+ mainwindow/widgets/navigationbar.cpp
+ mainwindow/widgets/navigationbar.h
+ mainwindow/widgets/searchform.cpp
+ mainwindow/widgets/searchform.h
+ mainwindow/widgets/searchform.ui
+
+ # address bar
+ addressbar/completer.cpp
+ addressbar/completer.h
+ addressbar/urllineedit.cpp
+ addressbar/urllineedit.h
+
+ # todo: move all to mainwindow
+ widgets/mainwindowmenubar.cpp
+ widgets/mainwindowmenubar.h
+ widgets/mainwindowtabbar.cpp
+ widgets/mainwindowtabbar.h
+
+ # webengine
+ webengine/cookieinterceptor.cpp
+ webengine/cookieinterceptor.h
+ webengine/urlinterceptor.cpp
+ webengine/urlinterceptor.h
+ webengine/webengineprofile.cpp # todo: rename to profile
+ webengine/webengineprofile.h
+ webengine/webpage.cpp
+ webengine/webpage.h
+ webengine/webview.cpp
+ webengine/webview.h
+
+ # forms
+ forms/aboutdialog.cpp
+ forms/aboutdialog.h
+ forms/aboutdialog.ui
+ # todo: move to webengine
+ #forms/cookiesform.cpp
+ #forms/cookiesform.h
+ #forms/cookiesform.ui
+
+ # plugin interfaces
+ ../plugins/interfaces.h commandline.cpp commandline.h)
+
+target_include_directories(poi
+ PRIVATE ../lib ../plugins)
+
+target_link_libraries(poi
+ Qt5::Core Qt5::Widgets Qt5::Concurrent Qt5::WebEngineWidgets
+ ${Boost_LIBRARIES}
+ bookmarks downloads)
+
+install(TARGETS poi RUNTIME DESTINATION bin CONFIGURATIONS Release)