aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build15
1 files changed, 4 insertions, 11 deletions
diff --git a/src/meson.build b/src/meson.build
index 1101b7a..6a4abd8 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -8,14 +8,14 @@ poi_settings_h = custom_target('default_config_value',
)
subdir('about')
+subdir('webengine')
poi_sourceset.add(mod_qt5.preprocess(
- moc_headers: ['browser.h',
+ moc_headers: ['browser.h', 'applicationmenu.h',
'mainwindow/mainwindow.h', 'mainwindow/addressbar.h', 'mainwindow/menubar.h', 'mainwindow/widgets/completer.h', 'mainwindow/widgets/urllineedit.h', 'mainwindow/widgets/dockwidget.h', 'mainwindow/widgets/navigationbar.h', 'mainwindow/widgets/searchform.h',
'bookmarks/bookmarkswidget.h', 'bookmarks/editbookmarkdialog.h',
'session/savesessiondialog.h', 'session/sessiondialog.h',
- 'subwindow/subwindow.h', 'subwindow/tabwidget.h',
- 'webengine/urlinterceptor.h', 'webengine/webpage.h', 'webengine/webview.h', 'webengine/webprofilemanager.h', 'webengine/webprofile.h'],
+ 'subwindow/subwindow.h', 'subwindow/tabwidget.h' ],
ui_files: [
'mainwindow/addressbar.ui', 'mainwindow/widgets/searchform.ui',
'bookmarks/bookmarksform.ui', 'bookmarks/editbookmarkdialog.ui',
@@ -27,7 +27,7 @@ poi_sourceset.add(mod_qt5.preprocess(
poi_sourceset.add(files(
'main.cpp', 'builtins.cpp',
- 'browser.cpp',
+ 'browser.cpp', 'applicationmenu.cpp',
'util.cpp', 'util.h',
'mainwindow/mainwindow.cpp',
@@ -48,13 +48,6 @@ poi_sourceset.add(files(
'subwindow/subwindow.cpp',
'subwindow/tabwidget.cpp',
- 'webengine/urlinterceptor.cpp',
- 'webengine/webpage.cpp',
- 'webengine/webview.cpp',
- 'webengine/webviewcontextmenu.cpp',
- 'webengine/webprofile.cpp',
- 'webengine/webprofilemanager.cpp',
-
'wallet/wallet.cpp', 'wallet/wallet.h'
),
version_h, poi_settings_h