aboutsummaryrefslogtreecommitdiff
path: root/staging/adblock/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'staging/adblock/meson.build')
-rw-r--r--staging/adblock/meson.build38
1 files changed, 0 insertions, 38 deletions
diff --git a/staging/adblock/meson.build b/staging/adblock/meson.build
deleted file mode 100644
index 942f325..0000000
--- a/staging/adblock/meson.build
+++ /dev/null
@@ -1,38 +0,0 @@
-lib_adblockfilter = static_library('adblockfilter',
- [ 'filterlist.cpp', 'options.cpp' ],
- include_directories: smolbote_interfaces,
- dependencies: [ dep_qt5 ]
-)
-
-dep_adblockfilter = declare_dependency(
- include_directories: ['.', smolbote_interfaces],
- link_with: lib_adblockfilter
-)
-
-#AdblockPlusFilterPlugin = shared_library('AdblockPlusPlugin',
-# [ 'plugin/plugin.cpp',
-# mod_qt5.preprocess(include_directories: smolbote_interfaces,
-# moc_headers: 'plugin/plugin.h', dependencies: dep_qt5)
-# ],
-# include_directories: smolbote_interfaces,
-# link_with: lib_adblockfilter,
-# dependencies: dep_qt5,
-# install: true,
-# install_dir: get_option('libdir')/'smolbote/plugins'
-#)
-
-test('adblock: rule', executable('libadblockfilter_rule',
- sources: 'test/rule.cpp',
- dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
-))
-
-test('adblock: options', executable('libadblockfilter_options',
- sources: 'test/options.cpp',
- dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
-))
-
-test('adblock: filterlist', executable('libadblockfilter_filterlist',
- sources: 'test/filterlist.cpp',
- dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
-))
-