aboutsummaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build34
1 files changed, 0 insertions, 34 deletions
diff --git a/test/meson.build b/test/meson.build
deleted file mode 100644
index 75e38ed..0000000
--- a/test/meson.build
+++ /dev/null
@@ -1,34 +0,0 @@
-dep_gtest = dependency('gtest')
-
-test('urlfilter-AdBlockList', executable('AdBlockList',
- dependencies: [dep_gtest, dep_qt5, dep_urlfilter],
- sources: ['urlfilter/urlfiltertest.cpp']
-))
-
-# Adblock parsing test
-adblock = executable('AdblockTest',
- dependencies: [dep_gtest, dep_qt5, dep_urlfilter],
- sources: ['adblock/adblocktest.cpp']
-)
-test('urlfilter-adblock', adblock, workdir: meson.current_source_dir())
-
-# Hostlist parsing test
-hostlist = executable('HostlistTest',
- dependencies: [dep_qt5, dep_urlfilter],
- sources: ['hostlist/hostlisttest.cpp', qt5.preprocess(moc_headers: 'hostlist/hostlisttest.h', dependencies: dep_qt5)]
-)
-test('urlfilter-hostlist', hostlist, workdir: meson.current_source_dir())
-
-# matching algorithms benchmark
-matcherbenchmark = executable('MatcherBenchmark',
- dependencies: [dep_qt5, dependency('boost', modules: 'regex')],
- sources: ['matcherbenchmark/matcherbenchmark.cpp', qt5.preprocess(moc_headers: 'matcherbenchmark/matcherbenchmark.h', dependencies: dep_qt5)]
-)
-
-# SingleApplication issue#40 test app
-singleapp = executable('SingleApplication',
- cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
- dependencies: [dep_qt5, dep_SingleApplication],
- sources: ['singleapplication-40/main.cpp']
-)
-