aboutsummaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index 9be99c9..df6a9c9 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -3,14 +3,14 @@ adblock = executable('AdblockTest',
dependencies: [dep_qt5, dep_urlfilter],
sources: ['adblock/adblocktest.cpp', qt5.preprocess(moc_headers: 'adblock/adblocktest.h', dependencies: dep_qt5)]
)
-test('urlfilter-adblock', adblock)
+test('urlfilter-adblock', adblock, workdir: meson.current_source_dir())
# Hostlist parsing test
hostlist = executable('HostlistTest',
dependencies: [dep_qt5, dep_urlfilter],
sources: ['hostlist/hostlisttest.cpp', qt5.preprocess(moc_headers: 'hostlist/hostlisttest.h', dependencies: dep_qt5)]
)
-test('urlfilter-hostlist', hostlist)
+test('urlfilter-hostlist', hostlist, workdir: meson.current_source_dir())
# matching algorithms benchmark
matcherbenchmark = executable('MatcherBenchmark',