aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-14 20:34:50 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-14 20:34:50 +0100
commit037b039bfbfeda2e9b7ebef7e38616575411c876 (patch)
tree6767f8edc0860b60b590dc30a37319a7c1c66a0d /CMakeLists.txt
parentMinor fixes (diff)
downloadsmolbote-037b039bfbfeda2e9b7ebef7e38616575411c876.tar.xz
Initial plugins testing
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 12afb57..7cb59e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,8 @@ add_subdirectory(lib/bookmarks)
add_subdirectory(lib/downloads)
add_subdirectory(lib/navigation)
+add_subdirectory(plugins/ProfileEditor)
+
# configure a header file to pass version information
# if you don't have git, or are building this off the source tarball, define versions in version.h.in
execute_process(COMMAND "git" "describe" WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE GitDescribe OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -102,11 +104,16 @@ set(SourceCode
"src/forms/cookiesform.cpp"
"src/forms/cookiesform.h"
"src/forms/cookiesform.ui"
+
+ # plugin interfaces
+ plugins/interfaces.h
)
add_executable(poi ${SourceCode})
-target_include_directories(poi PRIVATE src lib)
+target_include_directories(poi
+ PRIVATE src lib
+ PRIVATE plugins)
target_link_libraries(poi Qt5::Core Qt5::Widgets Qt5::Concurrent Qt5::WebEngineWidgets)
target_link_libraries(poi configuration)