aboutsummaryrefslogtreecommitdiff
path: root/lib/urlfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-16 17:25:40 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-16 17:25:40 +0200
commitc74367d82c1c7bec393548d2e5014c794333822f (patch)
tree909bcde935c84e566db528b1ab25d81778e13036 /lib/urlfilter/CMakeLists.txt
parentAdd workaround for QTBUG-62511 (diff)
downloadsmolbote-c74367d82c1c7bec393548d2e5014c794333822f.tar.xz
urlfilter: Add FilterTree class
FilterTree is a class that holds filter rules, sorted by the domain they are to be applied on. The rules are to follow FilterLeaf as interface. - Add a hostlist rule format to FilterTree. - Add a test for hostlist format.
Diffstat (limited to 'lib/urlfilter/CMakeLists.txt')
-rw-r--r--lib/urlfilter/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/urlfilter/CMakeLists.txt b/lib/urlfilter/CMakeLists.txt
index 842f18f..375ffa7 100644
--- a/lib/urlfilter/CMakeLists.txt
+++ b/lib/urlfilter/CMakeLists.txt
@@ -10,6 +10,15 @@ add_library(urlfilter
formats/adblockrule.cpp
formats/adblockrule.h
+
+ formats/hostlistrule.cpp
+ formats/hostlistrule.h
+
+ # filter tree
+ filtertree.cpp
+ filtertree.h
+ filterleaf.cpp
+ filterleaf.h
)
target_link_libraries(urlfilter Qt5::WebEngineWidgets)