aboutsummaryrefslogtreecommitdiff
path: root/lib/urlfilter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/urlfilter/CMakeLists.txt')
-rw-r--r--lib/urlfilter/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/urlfilter/CMakeLists.txt b/lib/urlfilter/CMakeLists.txt
index 842f18f..375ffa7 100644
--- a/lib/urlfilter/CMakeLists.txt
+++ b/lib/urlfilter/CMakeLists.txt
@@ -10,6 +10,15 @@ add_library(urlfilter
formats/adblockrule.cpp
formats/adblockrule.h
+
+ formats/hostlistrule.cpp
+ formats/hostlistrule.h
+
+ # filter tree
+ filtertree.cpp
+ filtertree.h
+ filterleaf.cpp
+ filterleaf.h
)
target_link_libraries(urlfilter Qt5::WebEngineWidgets)