aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-12-11 13:35:00 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-12-11 13:35:00 +0100
commit1e2034c9e3aef2b1eaeb2a622d5a59a956fb13f4 (patch)
tree18d70dd81a8dcb471081030dac1f3bf6d89f386b /linux/makepkg/PKGBUILD
parentAdd separate firejail .desktop (diff)
downloadsmolbote-1e2034c9e3aef2b1eaeb2a622d5a59a956fb13f4.tar.xz
Update poi_firejail.desktop
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 55eb000..3d75cf2 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -54,19 +54,15 @@ build() {
# --buildtype=plain - meson won't add any flags to the command line
# --prefix=... - install prefix
# --auto-features=disabled - features should be explicitly enabled
- meson --buildtype=plain --prefix=/usr/local --auto-features=disabled $srcdir/build
+ meson --buildtype=plain --prefix=/usr/local --auto-features=disabled \
+ -DPlasma=enabled -Dmanpage=enabled \
+ $srcdir/build
# Run menuconfig
#KCONFIG_CONFIG=linux/.config menuconfig
- cd $srcdir/build
-
- # Toggle features
- #meson configure -DBreakpad=enabled
- meson configure -DPlasma=enabled
- meson configure -Dmanpage=enabled
-
# Build
+ cd $srcdir/build
ninja
}