aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 55eb000..3d75cf2 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -54,19 +54,15 @@ build() {
# --buildtype=plain - meson won't add any flags to the command line
# --prefix=... - install prefix
# --auto-features=disabled - features should be explicitly enabled
- meson --buildtype=plain --prefix=/usr/local --auto-features=disabled $srcdir/build
+ meson --buildtype=plain --prefix=/usr/local --auto-features=disabled \
+ -DPlasma=enabled -Dmanpage=enabled \
+ $srcdir/build
# Run menuconfig
#KCONFIG_CONFIG=linux/.config menuconfig
- cd $srcdir/build
-
- # Toggle features
- #meson configure -DBreakpad=enabled
- meson configure -DPlasma=enabled
- meson configure -Dmanpage=enabled
-
# Build
+ cd $srcdir/build
ninja
}