aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2024-04-27 19:18:12 +0300
committeraqua <aqua@iserlohn-fortress.net>2024-04-27 19:31:41 +0300
commit289966819b657de3c1b1704555963ee77d9b60da (patch)
tree03dc994d72523e2c16fb2d4ef42e9b90ff410e1d /linux/makepkg/PKGBUILD
parentUpdated pkgbuild (diff)
downloadsmolbote-289966819b657de3c1b1704555963ee77d9b60da.tar.xz
Readded command line options
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 9f3fae9..9981f46 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -1,8 +1,6 @@
# Maintainer: Aqua-sama <aqua at iserlohn-fortress dot net>
## not-use flags
-# Enable plugin signing:
-_signPlugins=0
# install prefix
_prefix='/usr'
@@ -11,7 +9,7 @@ pkgdesc='Yet another no-frills browser'
pkgver=0
pkgrel=1
-url="https://neueland.iserlohn-fortress.net/gitea/smolbote"
+url="https://neueland.iserlohn-fortress.net/cgit/smolbote"
install="smolbote.install"
arch=('x86_64' 'aarch64')
@@ -21,19 +19,14 @@ depends=('qt6-svg' 'qt6-webengine' 'spdlog' 'fmt')
makedepends=('git' 'cmake' 'python-kconfiglib' 'openssl' 'qt6-tools' 'scdoc')
optdepends=('firejail: launch a sandboxed instance')
-# this isn't a hard requirement, simply a workaround as the build script
-# sets some additional hardening flags that the default makepkg.conf
-# will turn down
-options=(!buildflags)
-
# use git+file:///path/to/your/repo to build from a local repo
source=("git+https://neueland.iserlohn-fortress.net/cgit/smolbote"
- "https://github.com/itay-grudev/SingleApplication/archive/refs/tags/v3.4.1.tar.gz")
+ "SingleApplication-v3.4.1.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/refs/tags/v3.4.1.tar.gz")
-sha256sums=('SKIP'
- '7dfa5cafc30ae6d8b108fff7e99d35e52e728e9c2876202bcd612dbb75cc44ea')
+b2sums=('SKIP'
+ 'fe320ccb0390b13b1c7b0c017cff34b02f5138bd6643457843a7200374c8a994a37a1b00a65c70e83ba5bdc61f157ccfaa8cdfc0eee7b2149df4acda06173669')
-validgpgkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
+validpgpkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
prepare() {
mkdir "$srcdir/smolbote/third_party"
@@ -43,6 +36,7 @@ prepare() {
KCONFIG_CONFIG=linux/.config alldefconfig
cmake -S $srcdir/smolbote -B $srcdir/build \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
}
@@ -53,13 +47,12 @@ pkgver() {
}
build() {
- echo "make flags: ${MAKEFLAGS}"
- cmake --build $srcdir/build -j16
+ cmake --build $srcdir/build -- ${MAKEFLAGS}
}
-#check() {
-# ninja -C $srcdir/build test
-#}
+check() {
+ ctest --test-dir $srcdir/build
+}
package() {
DESTDIR="$pkgdir" cmake --install $srcdir/build --strip