aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-02-06 21:58:33 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2019-02-06 21:58:33 +0200
commite3e178e07c58f78eaa7066a64d2e6dd9acd66bd3 (patch)
treed172099b638563118a2df7d313fc96db72dd4889 /meson.build
parentFix all profiles being created off-the-record (diff)
downloadsmolbote-e3e178e07c58f78eaa7066a64d2e6dd9acd66bd3.tar.xz
Use spdlog for logging
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index be584ac..d4a8bd7 100644
--- a/meson.build
+++ b/meson.build
@@ -16,6 +16,9 @@ dep_qt5 = dependency('qt5', modules: ['Core', 'Network', 'Widgets', 'WebEngineWi
# Boost
dep_boost = dependency('boost', modules: ['program_options'])
+# spdlog
+dep_spdlog = dependency('spdlog', fallback: ['spdlog', 'spdlog_dep'], version: '>=1.3.1')
+
# Breakpad
if get_option('Breakpad').enabled()
dep_breakpad = declare_dependency(