aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 13:20:31 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 13:20:31 +0200
commit0851cfc8a01843d977fa19ef9fcb8d34546d6da4 (patch)
treefa47599979a9187cd1b14fca908a54626edc5d66 /src/meson.build
parentFix link errors (diff)
downloadsmolbote-0851cfc8a01843d977fa19ef9fcb8d34546d6da4.tar.xz
Fix SingleApplication segfault
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 63e7225..52c8d42 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -10,9 +10,9 @@ poi_moc = qt5.preprocess(
)
poi = executable('poi', install: true,
+ cpp_args: '-DQAPPLICATION_CLASS=QApplication',
dependencies: [dep_qt5, dep_boost, dep_breakpad, dep_SingleApplication,
dep_about, dep_addressbar, dep_bookmarks, dep_configuration, dep_downloads, dep_urlfilter, dep_web],
- cpp_args : '-DQAPPLICATION_CLASS=QApplication',
include_directories: [include, genheader_inc, lib_inc, thirdparty_inc],
sources: ['main.cpp', poi_moc,
'browser.cpp',