aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 11:53:50 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 11:53:50 +0200
commit547d6a4a8ed5ac2e8d922c0c7cfb294e0a3ceed4 (patch)
treea2aa608a744ba79ee84c495128df1059430f82a6 /src/meson.build
parentInitial meson build files (diff)
downloadsmolbote-547d6a4a8ed5ac2e8d922c0c7cfb294e0a3ceed4.tar.xz
Fix link errors
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build31
1 files changed, 17 insertions, 14 deletions
diff --git a/src/meson.build b/src/meson.build
index 83ef998..63e7225 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,6 +1,9 @@
# poi
poi_moc = qt5.preprocess(
- moc_headers: [],
+ moc_headers: ['browser.h', 'session.h',
+ 'mainwindow/mainwindow.h', 'mainwindow/widgets/dockwidget.h', 'mainwindow/widgets/navigationbar.h', 'mainwindow/widgets/searchform.h',
+ 'subwindow/subwindow.h', 'subwindow/tabwidget.h',
+ 'webengine/filter.h', 'webengine/urlinterceptor.h', 'webengine/webpage.h', 'webengine/webview.h'],
ui_files: ['mainwindow/mainwindow.ui', 'mainwindow/widgets/searchform.ui'],
qresources: '../data/resources.qrc',
dependencies: dep_qt5
@@ -12,22 +15,22 @@ poi = executable('poi', install: true,
cpp_args : '-DQAPPLICATION_CLASS=QApplication',
include_directories: [include, genheader_inc, lib_inc, thirdparty_inc],
sources: ['main.cpp', poi_moc,
- 'browser.cpp', 'browser.h',
- 'session.cpp', 'session.h',
+ 'browser.cpp',
+ 'session.cpp',
'util.cpp', 'util.h',
-
- 'mainwindow/mainwindow.cpp', 'mainwindow/mainwindow.h',
- 'mainwindow/widgets/dockwidget.cpp', 'mainwindow/widgets/dockwidget.h',
- 'mainwindow/widgets/navigationbar.cpp', 'mainwindow/widgets/navigationbar.h',
- 'mainwindow/widgets/searchform.cpp', 'mainwindow/widgets/searchform.h',
- 'subwindow/subwindow.cpp', 'subwindow/subwindow.h',
- 'subwindow/tabwidget.cpp', 'subwindow/tabwidget.h',
+ 'mainwindow/mainwindow.cpp',
+ 'mainwindow/widgets/dockwidget.cpp',
+ 'mainwindow/widgets/navigationbar.cpp',
+ 'mainwindow/widgets/searchform.cpp',
+
+ 'subwindow/subwindow.cpp',
+ 'subwindow/tabwidget.cpp',
- 'webengine/filter.cpp', 'webengine/filter.h',
- 'webengine/urlinterceptor.cpp', 'webengine/urlinterceptor.h',
- 'webengine/webpage.cpp', 'webengine/webpage.h',
- 'webengine/webview.cpp', 'webengine/webview.h',
+ 'webengine/filter.cpp',
+ 'webengine/urlinterceptor.cpp',
+ 'webengine/webpage.cpp',
+ 'webengine/webview.cpp',
'wallet/wallet.cpp', 'wallet/wallet.h']
)