aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-12-25 23:58:38 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-12-25 23:58:38 +0100
commit478cdbbc5cc1c69a76e6f1054ce70f8ee0bb0a59 (patch)
tree8e7bc642665ce0ce30466f10a0af26947e969250 /src/meson.build
parentFix bookmarks context menu exec position (diff)
downloadsmolbote-478cdbbc5cc1c69a76e6f1054ce70f8ee0bb0a59.tar.xz
Rename TabWidget::deleteTab to TabWidget::removeTab
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build11
1 files changed, 1 insertions, 10 deletions
diff --git a/src/meson.build b/src/meson.build
index 1fb4a98..f07a2ec 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -11,18 +11,9 @@ poi_moc = qt5.preprocess(
dependencies: dep_qt5
)
-optdepends = []
-if get_option('Breakpad').enabled()
- optdepends += dep_breakpad
-endif
-
-if get_option('Plasma').enabled()
- optdepends += dep_plasma
-endif
-
poi = executable(get_option('poiName'), install: true,
cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
- dependencies: [dep_qt5, dep_boost, dep_SingleApplication, dep_genheaders, optdepends,
+ dependencies: [dep_qt5, dep_boost, dep_SingleApplication, dep_genheaders, dep_breakpad, dep_plasma,
dep_about, dep_addressbar, dep_bookmarks, dep_configuration, dep_downloads, dep_urlfilter, dep_web],
include_directories: [include],
sources: ['main.cpp', 'builtins.cpp', 'crashhandler.cpp', poi_moc,