aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build11
1 files changed, 1 insertions, 10 deletions
diff --git a/src/meson.build b/src/meson.build
index 1fb4a98..f07a2ec 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -11,18 +11,9 @@ poi_moc = qt5.preprocess(
dependencies: dep_qt5
)
-optdepends = []
-if get_option('Breakpad').enabled()
- optdepends += dep_breakpad
-endif
-
-if get_option('Plasma').enabled()
- optdepends += dep_plasma
-endif
-
poi = executable(get_option('poiName'), install: true,
cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
- dependencies: [dep_qt5, dep_boost, dep_SingleApplication, dep_genheaders, optdepends,
+ dependencies: [dep_qt5, dep_boost, dep_SingleApplication, dep_genheaders, dep_breakpad, dep_plasma,
dep_about, dep_addressbar, dep_bookmarks, dep_configuration, dep_downloads, dep_urlfilter, dep_web],
include_directories: [include],
sources: ['main.cpp', 'builtins.cpp', 'crashhandler.cpp', poi_moc,