aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-24 13:09:45 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-24 13:09:45 +0200
commitb2fec872deea1e4e08f02ac74df383da3cb6665a (patch)
treedd1f2c26fde464e579094f16eae9e6422e176fba /src/meson.build
parentAdd plugins to meson build (diff)
downloadsmolbote-b2fec872deea1e4e08f02ac74df383da3cb6665a.tar.xz
Add missing install items
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index e09b130..715e154 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -6,6 +6,7 @@ poi_moc = qt5.preprocess(
'webengine/filter.h', 'webengine/urlinterceptor.h', 'webengine/webpage.h', 'webengine/webview.h'],
ui_files: ['mainwindow/mainwindow.ui', 'mainwindow/widgets/searchform.ui'],
qresources: '../data/resources.qrc',
+ rcc_extra_arguments: ['--format-version=1'],
dependencies: dep_qt5
)
@@ -44,3 +45,9 @@ poi = executable(get_option('poiName'), install: true,
'wallet/wallet.cpp', 'wallet/wallet.h']
)
+# install .desktop file and firejail profile
+if ['linux', 'freebsd', 'netbsd', 'dragonflybsd'].contains(host_machine.system())
+ install_data('../data/poi.svg', install_dir: join_paths(get_option('datadir'), 'icons/hicolor/scalable/apps'))
+ install_data('../linux/poi.desktop', install_dir: join_paths(get_option('datadir'), 'applications'))
+ install_data('../data/poi.profile', install_dir: join_paths(get_option('libdir'), 'smolbote'))
+endif