aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD98
1 files changed, 21 insertions, 77 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 5e27542..efdea15 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -1,53 +1,43 @@
# Maintainer: Aqua-sama <aqua at iserlohn-fortress dot net>
## not-use flags
-# Enable plugin signing:
-_signPlugins=0
-# Enable breakpad integraton:
-_enableBreakpad=0
# install prefix
-_prefix='/usr/local'
+_prefix='/usr'
pkgname=smolbote-git
pkgdesc='Yet another no-frills browser'
pkgver=0
pkgrel=1
-url="https://neueland.iserlohn-fortress.net/gitea/smolbote"
+url="https://neueland.iserlohn-fortress.net/cgit/smolbote"
install="smolbote.install"
arch=('x86_64' 'aarch64')
license=('GPL3')
-depends=('qt5-webengine>=5.11.0' 'spdlog')
-makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt5-tools' 'scdoc' 'catch2')
-if [ $_enableBreakpad == "1" ]; then
- makedepends+=('breakpad-git')
-fi
+depends=('qt6-svg' 'qt6-webengine' 'spdlog' 'fmt')
+makedepends=('git' 'cmake' 'openssl' 'qt6-tools' 'scdoc')
optdepends=('firejail: launch a sandboxed instance')
-# this isn't a hard requirement, simply a workaround as the build script
-# sets some additional hardening flags that the default makepkg.conf
-# will turn down
-options=(!buildflags)
-
# use git+file:///path/to/your/repo to build from a local repo
-source=("git+https://library.iserlohn-fortress.net/aqua/smolbote.git"
- "https://neueland.iserlohn-fortress.net/releases/SingleApplication-3.1.1a.tar.xz"{,.sig}
- "https://neueland.iserlohn-fortress.net/releases/args.hxx-6.2.2.tar.xz"{,.sig})
+source=("git+https://neueland.iserlohn-fortress.net/cgit/smolbote"
+ "SingleApplication-v3.4.1.tar.gz::https://github.com/itay-grudev/SingleApplication/archive/refs/tags/v3.4.1.tar.gz")
b2sums=('SKIP'
- 'cec3de8dbf252bfa6dc488e5a1440695f4dd3abffdf30948b7d1a3df3d9c85911e981c802ed5a882f1407315114529f4016e55c7d05fbbd1dafe5495b0a63f4a'
- 'SKIP'
- '440e357006883fbf1b1a796051500a6b068858a35947cd1119767bed8e0a86a7db4aff16498934d7217c375fe643da03c22007e438f30899e247153f25c922b6'
- 'SKIP')
+ 'fe320ccb0390b13b1c7b0c017cff34b02f5138bd6643457843a7200374c8a994a37a1b00a65c70e83ba5bdc61f157ccfaa8cdfc0eee7b2149df4acda06173669')
-validgpgkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
+validpgpkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
prepare() {
- mkdir "$srcdir/smolbote/subprojects/packagecache/"
- ln -s "$srcdir/SingleApplication-3.1.1a" "$srcdir/smolbote/subprojects/"
- ln -s "$srcdir/args.hxx-6.2.2" "$srcdir/smolbote/subprojects/"
+ msg2 "Populate third_party packages..."
+ mkdir "$srcdir/smolbote/third_party"
+ ln -s "$srcdir/SingleApplication-3.4.1" "$srcdir/smolbote/third_party/SingleApplication"
+
+ msg2 "Configure..."
+ cmake -S $srcdir/smolbote -B $srcdir/build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_MANPAGES=ON
}
pkgver() {
@@ -57,61 +47,15 @@ pkgver() {
}
build() {
- mkdir -p $srcdir/build
- cd $srcdir/smolbote
- KCONFIG_CONFIG=linux/.config alldefconfig
-
- # For a list of configureable options, check smolbote/meson_options.txt, or
- # run `meson configure` in $srcdir/build
-
- # --wrap-mode=nodownload - disable meson from downloading dependency wraps. This will cause it to fail if makedepends are not found by pkg-config or cmake.
- # --wrap-mode=nofallback - disable downloads as a fallback too. Implies --wrap-mode=nodownload
- # --buildtype=plain - meson won't add any flags to the command line
- # --prefix=... - install prefix
- # --auto-features=disabled - features should be explicitly enabled
- # b_pie: Build executables as position independent
- # b_lto: Use link time optimization
- meson --buildtype=release --wrap-mode=nodownload \
- --prefix=$_prefix --auto-features=disabled \
- -Db_pie=true -Ddefault_library=static \
- -Dmanpage=enabled \
- $srcdir/build
-
- if [ $_enableBreakpad == "1" ]; then
- msg2 "Enabling crashhandler"
- meson configure -Ddebug=true -Dcrashhandler=enabled
- KCONFIG_CONFIG=linux/.config setconfig USEBREAKPAD=y
- fi
-
- # Run menuconfig
- #KCONFIG_CONFIG=linux/.config menuconfig
-
- # Build
- ninja -C $srcdir/build "$MAKEFLAGS"
+ cmake --build $srcdir/build -- ${MAKEFLAGS}
+ cmake --build $srcdir/build --target manpages -- ${MAKEFLAGS}
}
check() {
- ninja -C $srcdir/build test
+ ctest --test-dir $srcdir/build
}
package() {
- # Install
- cd $srcdir/build
- DESTDIR="$pkgdir" ninja install
-
- if [ $_signPlugins == "1" ]; then
- msg "Signing plugins"
- for so in $pkgdir/$_prefix/lib/smolbote/plugins/*.so; do
- openssl dgst -sha256 -sign $srcdir/build/lib/pluginloader/privateKey.pem -out $so.sig $so
- msg2 "Signed $(basename $so)"
- done
- fi
-
- if [ $_enableBreakpad == "1" ]; then
- msg "Installing debug symbols"
- ninja -C $srcdir/build linux/poi.sym
- install -dm644 $pkgdir/$_prefix/lib/smolbote/symbols/poi/$(head -n1 linux/poi.sym | awk '{ print $(NF-1) }')
- install -m644 -t $pkgdir/$_prefix/lib/smolbote/symbols/poi/$(head -n1 linux/poi.sym | awk '{ print $(NF-1) }') $srcdir/build/linux/poi.sym
- fi
+ DESTDIR="$pkgdir" cmake --install $srcdir/build --strip
}